Scenario 5 Answer: IS-IS routing on Frame Relay Multi-point and Point-to-Point

This is the answer for Scenario 5: IS-IS routing on Frame Relay Multi-point and Point-to-Point.

Router 1 Configuration.

R1#sh run
Building configuration...

Current configuration : 870 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
!
ip subnet-zero
!
!
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 no ip address
 encapsulation frame-relay
!         
interface Serial0.1 multipoint
 ip address 20.20.20.1 255.255.255.248
 ip router isis 
 frame-relay map clns 222 broadcast
 frame-relay map clns 333 broadcast
 frame-relay map ip 20.20.20.2 222 broadcast
 frame-relay map ip 20.20.20.3 333 broadcast
 isis circuit-type level-2-only
!
interface Serial0.2 point-to-point
 ip address 30.30.30.1 255.255.255.252
 ip router isis 
 frame-relay interface-dlci 444   
 isis circuit-type level-1
!
interface Serial1
 no ip address
 shutdown
!
router isis 
 net 49.0001.0000.0000.000a.00
!
ip classless
ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end


Router 1 sh ip route.

Gateway of last resort is not set

     50.0.0.0/24 is subnetted, 1 subnets
i L1    50.50.50.0 [115/20] via 30.30.30.2, Serial0.2
     70.0.0.0/24 is subnetted, 1 subnets
i L1    70.70.70.0 [115/20] via 30.30.30.2, Serial0.2
     20.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
i L2    20.20.20.16/30 [115/20] via 20.20.20.2, Serial0.1
i L2    20.20.20.24/30 [115/20] via 20.20.20.2, Serial0.1
C       20.20.20.0/29 is directly connected, Serial0.1
i L2    20.20.20.8/30 [115/20] via 20.20.20.2, Serial0.1
     10.0.0.0/30 is subnetted, 4 subnets
i L2    10.10.10.8 [115/30] via 20.20.20.3, Serial0.1
i L2    10.10.10.12 [115/30] via 20.20.20.3, Serial0.1
i L2    10.10.10.0 [115/20] via 20.20.20.3, Serial0.1
i L2    10.10.10.4 [115/30] via 20.20.20.3, Serial0.1
     60.0.0.0/24 is subnetted, 1 subnets
i L1    60.60.60.0 [115/20] via 30.30.30.2, Serial0.2
     30.0.0.0/30 is subnetted, 1 subnets
C       30.30.30.0 is directly connected, Serial0.2

Router 2 Configuration.

R2#sh run
Building configuration...

Current configuration : 983 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
!
ip subnet-zero
!
!
!
!
interface Loopback0
 ip address 20.20.20.9 255.255.255.252
 ip router isis 
!
interface Loopback1
 ip address 20.20.20.17 255.255.255.252
 ip router isis 
!         
interface Loopback2
 ip address 20.20.20.25 255.255.255.252
 ip router isis 
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 20.20.20.2 255.255.255.248
 ip router isis 
 encapsulation frame-relay
 frame-relay map clns 111 broadcast
 frame-relay map clns 333 broadcast
 frame-relay map ip 20.20.20.1 111 broadcast
 frame-relay map ip 20.20.20.3 333 broadcast
 frame-relay lmi-type cisco
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
router isis 
 net 49.0002.0000.0000.000b.00
 is-type level-2-only
!
ip classless
ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Router 2 sh ip route.

Gateway of last resort is not set

     50.0.0.0/24 is subnetted, 1 subnets
i L2    50.50.50.0 [115/30] via 20.20.20.1, Serial0
     70.0.0.0/24 is subnetted, 1 subnets
i L2    70.70.70.0 [115/30] via 20.20.20.1, Serial0
     20.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C       20.20.20.16/30 is directly connected, Loopback1
C       20.20.20.24/30 is directly connected, Loopback2
C       20.20.20.0/29 is directly connected, Serial0
C       20.20.20.8/30 is directly connected, Loopback0
     10.0.0.0/30 is subnetted, 4 subnets
i L2    10.10.10.8 [115/30] via 20.20.20.3, Serial0
i L2    10.10.10.12 [115/30] via 20.20.20.3, Serial0
i L2    10.10.10.0 [115/20] via 20.20.20.3, Serial0
i L2    10.10.10.4 [115/30] via 20.20.20.3, Serial0
     60.0.0.0/24 is subnetted, 1 subnets
i L2    60.60.60.0 [115/30] via 20.20.20.1, Serial0
     30.0.0.0/30 is subnetted, 1 subnets
i L2    30.30.30.0 [115/20] via 20.20.20.1, Serial0

Router 3 Configuration.

R3#sh run
Building configuration...

Current configuration : 787 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
!
ip subnet-zero
!
!
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 20.20.20.3 255.255.255.248
 ip router isis 
 encapsulation frame-relay
 frame-relay map clns 111 broadcast
 frame-relay map clns 222 broadcast
 frame-relay map ip 20.20.20.1 111 broadcast
 frame-relay map ip 20.20.20.2 222 broadcast
 isis circuit-type level-2-only
!
interface Serial1
 ip address 10.10.10.2 255.255.255.252
 ip router isis 
 isis circuit-type level-1
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
router isis 
 net 49.0003.0000.0000.000c.00
!
ip classless
ip http server
!
!         
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Router 3 sh ip route.

Gateway of last resort is not set

     50.0.0.0/24 is subnetted, 1 subnets
i L2    50.50.50.0 [115/30] via 20.20.20.1, Serial0
     70.0.0.0/24 is subnetted, 1 subnets
i L2    70.70.70.0 [115/30] via 20.20.20.1, Serial0
     20.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
i L2    20.20.20.16/30 [115/20] via 20.20.20.2, Serial0
i L2    20.20.20.24/30 [115/20] via 20.20.20.2, Serial0
C       20.20.20.0/29 is directly connected, Serial0
i L2    20.20.20.8/30 [115/20] via 20.20.20.2, Serial0
     10.0.0.0/30 is subnetted, 4 subnets
i L1    10.10.10.8 [115/20] via 10.10.10.1, Serial1
i L1    10.10.10.12 [115/20] via 10.10.10.1, Serial1
C       10.10.10.0 is directly connected, Serial1
i L1    10.10.10.4 [115/20] via 10.10.10.1, Serial1
     60.0.0.0/24 is subnetted, 1 subnets
i L2    60.60.60.0 [115/30] via 20.20.20.1, Serial0
     30.0.0.0/30 is subnetted, 1 subnets
i L2    30.30.30.0 [115/20] via 20.20.20.1, Serial0

Router 4 Configuration.

R4#sh run
Building configuration...

Current configuration : 850 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R4
!
!
ip subnet-zero
!
!
!
!
interface Loopback0
 ip address 50.50.50.1 255.255.255.0
 ip router isis 
!
interface Loopback1
 ip address 60.60.60.1 255.255.255.0
 ip router isis 
!         
interface Loopback2
 ip address 70.70.70.1 255.255.255.0
 ip router isis 
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 no ip address
 encapsulation frame-relay
!
interface Serial0.1 point-to-point
 ip address 30.30.30.2 255.255.255.252
 ip router isis 
 frame-relay interface-dlci 111   
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
router isis 
 net 49.0001.0000.0000.000b.00
!
ip classless
ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Router 4 sh ip route.

Gateway of last resort is 30.30.30.1 to network 0.0.0.0

     50.0.0.0/24 is subnetted, 1 subnets
C       50.50.50.0 is directly connected, Loopback0
     70.0.0.0/24 is subnetted, 1 subnets
C       70.70.70.0 is directly connected, Loopback2
     60.0.0.0/24 is subnetted, 1 subnets
C       60.60.60.0 is directly connected, Loopback1
     30.0.0.0/30 is subnetted, 1 subnets
C       30.30.30.0 is directly connected, Serial0.1
i*L1 0.0.0.0/0 [115/10] via 30.30.30.1, Serial0.1

Router 5 Configuration.


R5#sh run
Building configuration...

Current configuration : 695 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R5
!
!
ip subnet-zero
!
!
!
!
interface Loopback0
 ip address 10.10.10.5 255.255.255.252
 ip router isis 
!
interface Loopback1
 ip address 10.10.10.9 255.255.255.252
 ip router isis 
!         
interface Loopback2
 ip address 10.10.10.13 255.255.255.252
 ip router isis 
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 10.10.10.1 255.255.255.252
 ip router isis 
 no fair-queue
 clockrate 56000
!
router isis 
 net 49.0003.0000.0000.000a.00
 is-type level-1
!
ip classless
ip http server
!
!
!         
line con 0
line 1 16
line aux 0
line vty 0 4
 login
!
end

Router 5 sh ip route.

Gateway of last resort is 10.10.10.2 to network 0.0.0.0

     10.0.0.0/30 is subnetted, 4 subnets
C       10.10.10.8 is directly connected, Loopback1
C       10.10.10.12 is directly connected, Loopback2
C       10.10.10.0 is directly connected, Serial0
C       10.10.10.4 is directly connected, Loopback0
i*L1 0.0.0.0/0 [115/10] via 10.10.10.2, Serial0

Leave a comment