Scenario 6: Multi Area EIGRP routing on Multipoint and Point-to-Point Frame Relay.

scenario6-figure1

Router 1 Configuration

hostname R1
!
interface Serial0
 no ip address
 encapsulation frame-relay
 frame-relay lmi-type cisco
!
interface Serial0.1 multipoint
 ip address 20.20.20.1 255.255.255.248
 frame-relay map ip 20.20.20.2 222 broadcast
 frame-relay map ip 20.20.20.3 333 broadcast
!
interface Serial0.2 point-to-point
 ip address 30.30.30.1 255.255.255.252
 frame-relay interface-dlci 444   
!
interface Serial1
 no ip address
 shutdown
!
router eigrp 20
 redistribute eigrp 30 metric 56 20000 255 1 1500
 network 20.0.0.0
 auto-summary
!
router eigrp 30
 redistribute eigrp 20 metric 56 20000 255 1 1500
 network 30.0.0.0
 auto-summary
!

Router 1 sh ip route

Gateway of last resort is not set

     20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D       20.20.20.0/27 [90/2297856] via 20.20.20.2, 00:10:13, Serial0.1
C       20.20.20.0/29 is directly connected, Serial0.1
     10.0.0.0/30 is subnetted, 1 subnets
D EX    10.10.10.0 [170/51346176] via 20.20.20.3, 00:10:23, Serial0.1
     30.0.0.0/30 is subnetted, 1 subnets
C       30.30.30.0 is directly connected, Serial0.2

Router 2 Configuration

hostname R2
!
interface Loopback0
 ip address 20.20.20.9 255.255.255.248
!
interface Loopback1
 ip address 20.20.20.17 255.255.255.248
!
interface Loopback2
 ip address 20.20.20.25 255.255.255.248
!
interface Serial0
 ip address 20.20.20.2 255.255.255.248
 encapsulation frame-relay
 ip summary-address eigrp 20 20.20.20.0 255.255.255.224 5
 frame-relay map ip 20.20.20.1 111 broadcast
 frame-relay map ip 20.20.20.3 333 broadcast
 frame-relay lmi-type cisco
!
router eigrp 20
 network 20.0.0.0
 auto-summary
!

Router 2 sh ip route

Gateway of last resort is not set

     20.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C       20.20.20.16/29 is directly connected, Loopback1
C       20.20.20.24/29 is directly connected, Loopback2
D       20.20.20.0/27 is a summary, 00:16:09, Null0
C       20.20.20.0/29 is directly connected, Serial0
C       20.20.20.8/29 is directly connected, Loopback0
     10.0.0.0/30 is subnetted, 1 subnets
D EX    10.10.10.0 [170/51346176] via 20.20.20.3, 00:12:26, Serial0
     30.0.0.0/30 is subnetted, 1 subnets
D EX    30.30.30.0 [170/51346176] via 20.20.20.1, 00:11:27, Serial0

Router 3 Configuration

hostname R3
!
interface Serial0
 ip address 20.20.20.3 255.255.255.248
 encapsulation frame-relay
 frame-relay map ip 20.20.20.1 111 broadcast
 frame-relay map ip 20.20.20.2 222 broadcast
 frame-relay lmi-type cisco
!
interface Serial1
 ip address 10.10.10.2 255.255.255.252
!
router eigrp 10
 redistribute eigrp 20 metric 56 20000 255 1 1500
 network 10.0.0.0
 auto-summary
!
router eigrp 20
 redistribute eigrp 10 metric 56 20000 255 1 1500
 network 20.0.0.0
 auto-summary
!

Router 3 sh ip route

Gateway of last resort is not set

     20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D       20.20.20.0/27 [90/2297856] via 20.20.20.2, 00:14:12, Serial0
C       20.20.20.0/29 is directly connected, Serial0
     10.0.0.0/30 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Serial1
     30.0.0.0/30 is subnetted, 1 subnets
D EX    30.30.30.0 [170/51346176] via 20.20.20.1, 00:13:20, Serial0

Router 4 Configuration

hostname R4
!
interface Loopback0
 ip address 30.30.30.5 255.255.255.252
!
interface Loopback1
 ip address 30.30.30.9 255.255.255.252
!
interface Loopback2
 ip address 30.30.30.13 255.255.255.252
!
interface Serial0
 ip address 30.30.30.2 255.255.255.252
 encapsulation frame-relay
 frame-relay interface-dlci 111
 frame-relay lmi-type cisco
!
router eigrp 30
 network 30.0.0.0
 auto-summary
 eigrp stub receive-only
!

Router 4 sh ip route

Gateway of last resort is not set

     20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D EX    20.20.20.0/27 [170/51346176] via 30.30.30.1, 00:13:57, Serial0
D EX    20.20.20.0/29 [170/51346176] via 30.30.30.1, 00:27:53, Serial0
     10.0.0.0/30 is subnetted, 1 subnets
D EX    10.10.10.0 [170/51346176] via 30.30.30.1, 00:14:07, Serial0
     30.0.0.0/30 is subnetted, 4 subnets
C       30.30.30.12 is directly connected, Loopback2
C       30.30.30.8 is directly connected, Loopback1
C       30.30.30.4 is directly connected, Loopback0
C       30.30.30.0 is directly connected, Serial0

Router 5 Configuration


hostname R5
!
interface Loopback1
 ip address 10.10.10.9 255.255.255.252
!
interface Loopback2
 ip address 10.10.10.13 255.255.255.252
!
interface Serial0
 ip address 10.10.10.1 255.255.255.252
 ip summary-address eigrp 10 10.10.10.0 255.255.255.240 5
 no fair-queue
 clockrate 56000
!
router eigrp 10
 network 10.0.0.0
 no auto-summary
 eigrp stub receive-only
!

Router 5 sh ip route

Gateway of last resort is not set

     20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D EX    20.20.20.0/27 [170/51346176] via 10.10.10.2, 00:10:48, Serial0
D EX    20.20.20.0/29 [170/51346176] via 10.10.10.2, 00:21:04, Serial0
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C       10.10.10.8/30 is directly connected, Loopback1
C       10.10.10.12/30 is directly connected, Loopback2
D       10.10.10.0/28 is a summary, 01:39:27, Null0
C       10.10.10.0/30 is directly connected, Serial0
C       10.10.10.4/30 is directly connected, Loopback0
     30.0.0.0/30 is subnetted, 1 subnets
D EX    30.30.30.0 [170/51346176] via 10.10.10.2, 00:09:06, Serial0

2 thoughts on “Scenario 6: Multi Area EIGRP routing on Multipoint and Point-to-Point Frame Relay.

  1. hi,

    have you done these diagramms with kivio? i wonder where do you have these connectors. i didn’t found them on the stencils.

    fu

Leave a comment