OSPF Network Types: Point-to-Multipoint – RFC Standard

  • Partial-mesh or star network topology.
  • One IP Subnet.
  • Hello Timer 30 seconds.
  • Automatic adjacency, no DR/BDR elected.

R1#sh run int s1/0
Building configuration...

Current configuration : 273 bytes
!
interface Serial1/0
 ip address 192.168.1.1 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 serial restart-delay 0
 frame-relay map ip 192.168.1.2 102 broadcast
 frame-relay map ip 192.168.1.3 103 broadcast
 no frame-relay inverse-arp
end

R1#sh run | s router ospf
router ospf 1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 192.168.1.0 0.0.0.255 area 0

R1#sh ip ospf nei

Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/  -        00:01:36    192.168.1.2     Serial1/0
3.3.3.3           0   FULL/  -        00:01:32    192.168.1.3     Serial1/0

R1#debug ip ospf hello 
OSPF hello events debugging is on
R1#
*Mar  1 02:50:50.839: OSPF: Rcv hello from 3.3.3.3 area 0 from Serial1/0 192.168.1.3
*Mar  1 02:50:50.843: OSPF: End of hello processing
*Mar  1 02:50:54.995: OSPF: Rcv hello from 2.2.2.2 area 0 from Serial1/0 192.168.1.2
*Mar  1 02:50:54.995: OSPF: End of hello processing
*Mar  1 02:50:57.883: OSPF: Send hello to 224.0.0.5 area 0 on Serial1/0 from 192.168.1.1

R1#sh ip ospf int s1/0
Serial1/0 is up, line protocol is up 
  Internet Address 192.168.1.1/24, Area 0 
  Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_MULTIPOINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    oob-resync timeout 120
    Hello due in 00:00:12
  Supports Link-local Signaling (LLS)
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 2, Adjacent neighbor count is 2 
    Adjacent with neighbor 2.2.2.2
    Adjacent with neighbor 3.3.3.3

R2#sh run int s1/0
Building configuration...

Current configuration : 273 bytes
!
interface Serial1/0
 ip address 192.168.1.2 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 serial restart-delay 0
 frame-relay map ip 192.168.1.1 201 broadcast
 frame-relay map ip 192.168.1.3 203 broadcast
 no frame-relay inverse-arp
end

R2#sh run | s router ospf
router ospf 1
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 192.168.1.0 0.0.0.255 area 0
R2#sh ip ospf nei

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           0   FULL/  -        00:01:59    192.168.1.1     Serial1/0
3.3.3.3           0   FULL/  -        00:01:53    192.168.1.3     Serial1/0
R3#sh run int s1/0
Building configuration...

Current configuration : 273 bytes
!
interface Serial1/0
 ip address 192.168.1.3 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 serial restart-delay 0
 frame-relay map ip 192.168.1.1 301 broadcast
 frame-relay map ip 192.168.1.2 302 broadcast
 no frame-relay inverse-arp
end

R3#sh run | s router ospf
router ospf 1
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 192.168.1.0 0.0.0.255 area 0
R3#sh ip ospf nei

Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/  -        00:01:32    192.168.1.2     Serial1/0
1.1.1.1           0   FULL/  -        00:01:35    192.168.1.1     Serial1/0

Leave a comment